Menu

Menu bar is used to perform basic program operations. Some of the actions can also be performed via toolbar buttons.

The File Menu

The File menu is used to perform basic operations with projects, templates, and settings.

File > New project is used to create a new project. This task can also be accomplished using the New button in the toolbar. In a sub-menu you should also select one of the import modules that match your data source.

File > New project > CSV/XLS/XLSX connection is used to connect your data files, this can be one or several Excel files or ASCI files with delimiters, for example, files with extensions .csv, .txt, etc.

File > New project > ODBC/OLEDB connection is used to connect various databases. Most database vendors provide at least a minimal ODBC driver with their database. This import module requires knowledge of SQL queries.

File > New project > Order list connection available in the Business Forecasting package is used to extract historical demand from the raw list of customer orders. The module is only available in the 'Business forecasting' version of GMDH Shell.

File > New project > Sage Accounting connection available in the Business Forecasting package is used to easily extract retail sales data from 'Sage 50' and other versions of Sage accounting software (www.sage.co.uk). The module is only available in the 'Business forecasting' version of GMDH Shell.

File > Open project is used to open an existing forecast project. This task can also be accomplished using the the Open button in the toolbar. ' File > Save project is used to save the current project. The save-file with extension .gsp includes all settings, models and predictions, but does not include initial data loaded from a data source.

File > Save project as is used to save and name the current project. In the Save as type list of the dialog you can choose to save the project without the simulation results.

File > Recent projects is used to access the list of recently opened projects and open one of them again.

File > Revert to saved is used to drop all unsaved changes to the current project.

File > Reload data is used to update data in the Data explorer by connecting to your data source and repeating the import operation.

File > Change dataset is used to connect other data source, for example, a different file to existing project without creating and configuring a new project.

File > Show data file is used to open the imported file in its default editor, for example, for XLS-files this command will open the file in Excel. This operation is not applicable to multiple files or non-file data sources.

File > Load template is used to load a predefined configuration of GMDH Shell called the template. templates are used to solve different modeling and forecasting tasks. Depending on the installation type of GMDH Shell the set of built-in templates differ.

File > Save as template is used to add current project settings to the library of templates.

File > Exit is used to exit GMDH Shell.

The View Menu

The View menu is used to switch layouts, open or hide tabs and panels.

View > Home page is used to open or hide the Home page tab.

View > Experimenter's sidebar is used to open an advanced layout that shows Solver and Post-process settings in the sidebar.

View > Data explorer is used to open or hide the Data explorer tab that allows data exploration and visualisation.

View > Variables & transformations is used to open or hide the Variables & transformations panel.

View > Solver is used to open or hide the Solver panel.

View > Postprocess is used to open or hide the Postprocess panel.

View > Processing results is a group of tabs that show processing results.

View > Processing results > Plot is used to open or hide the Plot tab.

View > Processing results > Confusion matrix is used to open or hide the Confusion matrix tab.

View > Processing results > Table is used to open or hide the Table tab.

View > Processing results > Residuals is used to open or hide the Residuals tab.

View > Processing results > Accuracy is used to open or hide the Accuracy tab.

View > Processing results > Raw model is used to open or hide the Raw model tab.

View > Processing results > Importance of variables is used to open or hide the Importance of variables tab.

View > Forecast report is used to open or hide the Forecast report.

View > Inventory planing available in the Business Forecasting package is used to open or hide the Inventory planing report.

The Process Menu

The Process menu is used to perform modeling and forecasting.

Process > Forecast is used to create models and calculate predictions.

Process > Stop is used to interrupt the processing.

Process > Apply to new data (Scoring) is used to calculate predictions for a new dataset using the models obtained in the current project.

Process > Wizard is used to launch an assistant dialog that helps to configure a new processing task.

The Export Menu

The Export menu is used to save models, predictions and preprocessed data to spreadsheets. A file with the export results will be opened immediately.

Export > Export predictions is used to export postprocessed predictions.

Export > Export raw model > Spreadsheet formula is used to export a raw model formula selected in the Model browser to a spreadsheet and then apply the model right in the Excel file.

Export > Export raw model > Text formula is used to export a raw model formula selected in the Model browser to a text file.

Export > Export raw model > Model values is used to export predictions of a raw model selected in the Model browser to a spreadsheet.

Export > Show exported spreadsheet is used to open the last exported spreadsheet.

Export > Export preprocessed dataset to is used to export preprocessing results to a separate spreadsheet or a CSV file.

Export > Execute export plug-in is used to execute the Export plug-in which is normally executed only when GMDH Shell was launched using the command line.

The Help Menu

The Help menu is used to get On-line help, check for updates and manage GMDH Shell registration.

Help > Help online is used to open the online documentation in your default browser.

Help > Feedback and support is used to send GMDH Shell team a question or feedback about the program.

Help > Check for updates is used to perform a check for new version.

Help > About is used to store some important information about GMDH Shell and the registration information.

You are here: IntroductionMenu
CC Attribution-Noncommercial 3.0 Unported
Valid CSS Driven by DokuWiki Recent changes RSS feed Valid XHTML 1.0